Translation 1.3 to 2.0?

Avatar

By Vadim 27 April 2016 06:02

Member · 224 comments

Hi! 😁
How to update the translation from version 1.3 to version 2.0?

I want to update the translation (https://github.com/GetLuna/Luna-Transla … er/Russian)
From zero to translate a very long time. There are 1178 lines.

How to do it quickly?
I use Poedit.

Thanks!


I do not understand the code. I am learning English.

Avatar

By Yannick 27 April 2016 10:59

Administrator · 1,390 comments

Just click update.


You can do anything

Avatar

By Vadim 27 April 2016 11:57

Member · 224 comments

I do not know how to do that.
You can detailed instructions?


I do not understand the code. I am learning English.

Avatar

By Yannick 27 April 2016 18:59

Administrator · 1,390 comments

Open Poedit, open your translation, hit "Update".


You can do anything

Avatar

By Vadim 28 April 2016 10:30

Member · 224 comments

Hi Yannick!

I compared the two files English and Nederlands. I using Meld program (meldmerge.org).
And in the file Nederlands saw a lot of bugs and debris.

\Luna-luna-2.0-rc.1\lang\English\luna.po
\Luna-luna-2.0-rc.1\lang\Nederlands\luna.po

When I updated my file, and then compare, see the same mistakes. I manually corrected.
I think you should also check the file \Nederlands\luna.po

Last edited by Vadim (28 April 2016 10:31)


I do not understand the code. I am learning English.

Avatar

By Yannick 28 April 2016 19:59

Administrator · 1,390 comments

These files are generated by PoEdit itself. I can't see what could possibly be wrong with them.


You can do anything

Avatar

By Vadim 29 April 2016 09:31

Member · 224 comments

When I compared the files, I saw that "Poedit" made mistakes.


I do not understand the code. I am learning English.

Avatar

By Vadim 10 May 2016 12:35

Member · 224 comments

I've updated the Russian language (for Luna 2.0.0).
External forum - 98%
Backstage forum - 60%

In what folder I put these files on GitHub?
https://github.com/GetLuna/Luna-Translations (with the replacement?)
Or version 1.3 should be left?

Last edited by Vadim (10 May 2016 12:36)


I do not understand the code. I am learning English.

Avatar

By Yannick 10 May 2016 20:48

Administrator · 1,390 comments

Just replace the Russian translation, that repository is ment to contain only the latest releases and if one needs the older versions they can still download it from the repositories history.


You can do anything