Technology support for Luna "Glitter"

Avatar

By Yannick 14 August 2016 17:35

Administrator · 1,390 comments

As development of the Fallow and Glitter updates are well underway, it is time to reflect - as with every release - the technologies we support. With Luna 1.1.0, we started official support of PHP7 and MySQL 3 (which later also appeared in version 1.0.7). And as recent as version 2.0.0, we dropped left-over fixes for PHP 5.2 and lower.

MySQL
With Glitter, we are looking into dropping support for MySQL 5.1. This means that you'll need the next version of MySQL, which is version 5.5. As this version is already widespread, we don't expect this to become a problem for many people.

PostgreSQL
Current versions of Luna support PostgreSQL 8.4. Like with MySQL, we're planning to bump this requirement to version 9.1.

SQLite
SQLite 2 received its final update back in 2005, a good 11 years ago. With that, it is by far the oldest technology we support. And that is coming to an end. As of Luna 3.0, SQLite 3.5.1 or higher will be required. I would like to reserve the right to move this up to SQLite 3.6 or even 3.7.

PHP
Additionally, I would like to urge all of you running PHP 5.3 to start taking a look at more recent version of the platform as well. We're not planning to drop support for PHP 5.3 in the foreseeable future, but it is always good to be ahead of the curve.

---

For all of these technologies, the Fallow-update will be the last one to officially support them. Keep in mind that us dropping support doesn't mean Luna 3.0 will suddenly stop working. We just aren't going to fix issues that appear only on these outdated versions. The only thing that actually stops working is SQLite 2.x-support, as the database layer will be removed. You can't get out of these old technologies yet? Don't worry, we're planning to provide longer support for Luna 2.1, consider it an LTS-release. 😉

Have a great weekend!
- Yannick


You can do anything