Luna 1.3 and onwards will require PHP 5.3 or higher

Avatar

By Yannick 27 October 2015 20:48

Administrator · 1,390 comments

Hey everybody

As the world moves on to more recent versions of PHP, so should Luna. Every version up until now - Aero, Bittersweet Shimmer and Cornflower Blue - have required you to use PHP 5.2 or higher. However, this version of PHP will soon celebrate it's 9th anniversary and is almost left without support for 5 years now by the PHP Group.

And we think that Luna 1.3 will be a good point to move forward, to the more recent PHP 5.3 (which is still old, 6 years in fact, of which 1 year without support already). As some of you may know, our policy is to support the oldest PHP version with 10% market share according to WordPress and all version newer than that, and PHP 5.2 is currently holding 11,4%. With a rate of -,8% each month, this version will no longer have that threshold by the end of the year which is our target for the Denim update. Maybe - and I say MAYBE - this system requirement will stay on 5.2 for Denim, but by the time Emerald rolls out, it will be 5.3.

So there you have it, we're moving on, and I hope all of you are moving on to. Early next month, the next generation of PHP will be released under the name of PHP 7.0, so it's time to move on. We'll continue to support PHP 5.3 for many months to come (at the current rate, that will be around ~20 months as it now has 29,4%). So dropping of support for that version is a long run from now. 😁 For those that might have missed it: yes, Luna does support PHP 7, but that does require you to run 1.0.7 and higher, 1.1.0 and higher or 1.2.0

Have a great day and stay up-to-date! You should be running PHP 5.6 in fact (and next month this time 7.0 😁).
- Yannick


You can do anything

Avatar

By Yannick 27 October 2015 20:49

Administrator · 1,390 comments

By the way, this is me trying to make up for the horrible summer we've had here. Or winter, depending on where you live.


You can do anything

Avatar

By Sfideremo 27 October 2015 21:34

Member · 20 comments

Honestly, if your host is running less than 5.5, you should get a new host.

Avatar

By Yannick 28 October 2015 05:07

Administrator · 1,390 comments
Sfideremo wrote

Honestly, if your host is running less than 5.5, you should get a new host.

Sadly enough, it's not that common of a version. Only 19% has a PHP version above 5.5, and 80% of the market is just to much to leave behind. And since we don't need PHP 5.4/5.5/5.6 specific features, there is no reason to go that high just yet. 😁


You can do anything

Avatar

By Lirodon 28 October 2015 18:48

Member · 25 comments

We run 5.6.99-hhvm with APC; I think we're more than prepared.

Avatar

By Sfideremo 30 October 2015 05:29

Member · 20 comments
Yannick wrote
Sfideremo wrote

Honestly, if your host is running less than 5.5, you should get a new host.

Sadly enough, it's not that common of a version. Only 19% has a PHP version above 5.5, and 80% of the market is just to much to leave behind. And since we don't need PHP 5.4/5.5/5.6 specific features, there is no reason to go that high just yet. 😁

No reason? How about... security?
Just recently, 000webhost was hacked. Why? Outdated PHP. http://www.inquisitr.com/2529023/000web … g-service/
There's no reason not to update.

Avatar

By Yannick 30 October 2015 07:59

Administrator · 1,390 comments
Sfideremo wrote
Yannick wrote
Sfideremo wrote

Honestly, if your host is running less than 5.5, you should get a new host.

Sadly enough, it's not that common of a version. Only 19% has a PHP version above 5.5, and 80% of the market is just to much to leave behind. And since we don't need PHP 5.4/5.5/5.6 specific features, there is no reason to go that high just yet. 😁

No reason? How about... security?
Just recently, 000webhost was hacked. Why? Outdated PHP. http://www.inquisitr.com/2529023/000web … g-service/
There's no reason not to update.

Supporting older versions of PHP isn't going to make Luna less secure, so no, for our project it wouldn't make sense to already require higher versions without there being any ground for that.


You can do anything