Luna 2/3: Dropping emoticons

Avatar

By Yannick 12 April 2016 12:26

Administrator · 1,387 comments

Hello everybody,

Today I would like to start a discussion about emoticons. Back in the early days of Luna 0.x, we did not support emoticons (it was later added as a fall back). With the coming Luna 2 release, emoticons will no longer be the default, instead Luna will always opt for the emoji set that is native to your system. For now, the Luna 2.x-series will continue to support emoticons. However, with the next major release, I'm planning to drop emoticons entirely as part of a serious parser and Backstage-cleanup.

Unlike emoji's, emoticons don't scale well, do not have a native look and hold back the performance of Luna. This is why I'm considering to drop them. In a world where High-DPI becomes the norm, not scaling just isn't acceptable.

However, there are a couple of systems that do not support emoji's, that being Windows XP, Vista and OS X 10.6 and lower. These OS'es will no longer be able to see emoticons on Luna based forums, which shouldn't be an issue. All other operating systems that are in active use do support colored emoji's with the exception of Windows 7, which will fall back to black-and-white emoji's. Another exception on this rule is for Chrome in combination with any version of Windows (7, 8, 8.1 and 10) which will also fall back to black-and-white as long as you are using one of the more recent versions. If you are running Chrome and want to see colored emoji's, I suggest you start using a plugin for that, like Emoji One.

If you use Edge, Firefox or Internet Explorer you are fine and will see emoji's on Windows. For the best emoji experience I would suggest you to make sure you are running Windows 10 or at least Windows 8.1 as for Firefox and Internet Explorer, Windows 7 will, as said before, show emoji's in black-and-white. For OS X 10.7, 10.8 and 10.9 users, the same applies: make sure you're using either Safari or Firefox. If you are using Chrome, you need OS X 10.10 and up for emoji support. For Android, minimum version 4.4 is required for emoji support. For iOS, while version 5 already support emoji's, we strong recommend you to use at least iOS 7 or up.

Have a nice day
-- Yannick


You can do anything