Giving users forum specific permissions

Avatar

By Roel 18 December 2016 11:14

Member · 3 comments

Hello,
I can't give forum specific permissions to users with a moderator rank. In the backstage it says that I have to give them forum-specific permissions, but I can't do that in their profile. Is there something I do wrong?

Moderator group settings:
b2ce5fc663.png

Their profile:
ce430be767.png

I can give forum specific permissions to admins but that makes no sense because they already have all permissions.

Avatar

By Yannick 18 December 2016 19:43

Administrator · 1,387 comments

Yes, there is a bug in the admin panel that causes the settings to disappear after manipulating the admin settings. It will be fixed in 2.0.8.


You can do anything

Avatar

By bem 18 January 2017 16:20

Member · 118 comments

Hi Yannick, any idea when 2.0.8 will be ready? I have a moderator that has no moderator privileges which kind of makes him a pointless moderator. I usually wouldn't mind, but he's the other side of the world to me so is on the forum when I'm asleep and I wanted him to be able to deal with the occasional spam that get's through.

Avatar

By Yannick 18 January 2017 20:32

Administrator · 1,387 comments

I'm sorry that it has been taking so long, but sadly, I won't have much time to push out a fix right now.

What you could do in the meantime is going to Luna\themes\Fifteen\views\settings.php

and change this line (513):

<?php } else if ($user['g_moderator'] == '1' || $user['g_id'] == LUNA_ADMIN) { ?>

into

<?php } if ($user['g_moderator'] == '1'  && $luna_user['g_id'] == LUNA_ADMIN) { ?>

You can do anything

Avatar

By bem 18 January 2017 21:58

Member · 118 comments

That doesn't seem to work for me unfortunately.

If I go to the settings of another administrator on the forum, I now get the option to ban/delete that I haven't seen on any other user before. But I also get to select which options to set him as moderator for - but he's an admin, so doesn't apply for him.

On the moderators profile, it's the same as everyone else on the forum. Settings just gives me User Group, Comments & Admin Note.

Avatar

By Yannick 19 January 2017 09:10

Administrator · 1,387 comments

My bad, should have been the following. Sorry.

<?php } if ($user['g_moderator'] == '1'  && $luna_user['g_id'] == LUNA_ADMIN) { ?>

You can do anything

Avatar

By bem 19 January 2017 15:54

Member · 118 comments

That seems to have worked perfectly. Thank you!