php 5.2.17 translation problem

Avatar

By bem 15 December 2018 09:36

Member · 134 comments

Hi, my web hosting company upgraded their PHP version yesterday. Can't remember what it was, but it is now 5.2.17
This caused my forums to stop working with the good old 500 internal error. Looking at the error logs, this was the result of one of the translation files.

[15-Dec-2018 09:31:28] PHP Parse error:  syntax error, unexpected T_FUNCTION in /include/pomo/Translations/GettextTranslations.php on line 63

I've commented out that line and the forum is working again. Not sure what problems that will actually cause me, but thought you should know.

Avatar

By bem 15 December 2018 09:43

Member · 134 comments

Actually there's more. It seems to kill the parser file as well with unexpected T_FUNCTION errors.

There's also  Call to undefined function  parse_message()

Wishing my hosting company hadn't done any upgrades right now...

Avatar

By Yannick 16 December 2018 18:40

Administrator · 1,456 comments

Are you sure it is 5.2 and not 7.2? Note that Luna isn't supported on PHP 5.2. PHP 5.3 is required for Luna 2.0, PHP 5.4 for Luna 2.1.


You can do anything

Avatar

By bem 17 December 2018 13:48

Member · 134 comments

It might have been. I've got them to change it back to what it was before and it's all working again now. Which is a bit of a pain as it's always nice when your hosting company wants to give you a bit of an upgrade.

EDIT: Yeah, it definitely wasn't 5.2.17 haha. Reverted back to what it was previously and the PHP version is 5.6.37. If only I wasn't so annoyed at my hosting company at the time, I would have wrote the initial post correctly. But anyway, they upgraded the PHP version and it broke Luna entirely.

Last edited by bem (18 December 2018 18:13)

Avatar

By Yannick 23 December 2018 15:48

Administrator · 1,456 comments

Can you tell me which exact version they upgraded you too and if there are any special configurations on it?


You can do anything

Avatar

By bem 24 December 2018 11:43

Member · 134 comments

The other sites with the same company have been updated to 7.0.31
No special configurations that I know off.